Linux发行版高危严重漏洞 CVE-2018-14665

  • A+
所属分类:网络安全新闻

Linux发行版高危严重漏洞 CVE-2018-14665

安全研究人员在X.OrgServer软件包中发现了一个影响主要Linux发行版的高度严重漏洞CVE-2018-14665)。

安全研究员NarendraShinde在X.OrgServer软件包中发现了一个非常关键的漏洞(CVE-2018-14665),它影响了主要的Linux发行版,包括OpenBSD,Debian,Ubuntu,CentOS,RedHat和Fedora。

XorgX项目提供了XWindow系统的开源实现(也就是X11,或简称X,它是位图显示的窗口系统。它提供了GUI环境的基本框架:在显示设备上绘制和移动窗口以及交互用鼠标和键盘。

Shinde发现XorgX服务器无法正确处理和验证至少以下两个命令行参数的参数:

-modulepath:设置搜索Xorg服务器模块的目录路径,
-logfile:为Xorg服务器设置新的日志文件,而不是在大多数平台上使用位于/var/log/Xorg.n.log的默认日志。
根据NarendraShinde的说法,低权限用户可以利用它来执行恶意代码并覆盖系统上的任何文件

X.orgXServer应用程序容易受到权限提升问题的影响。X.orgXServer应用程序允许较低特权的用户在系统的任何地方创建或覆盖文件,包括特权用户拥有的文件(例如/etc/shadow)。读取专家发布的建议。

攻击者需要有活动的控制台会话来利用这个问题。

两年多前,该漏洞被引入X.Org服务器1.19.0软件包中。

Xorg发布了有关CVE-2018-14665漏洞的安全公告。

当X服务器以提升的权限运行时(即,安装Xorg并设置setuid位并由非root用户启动)。读取Xorg建议。

-modulepath参数可用于指定要在X服务器中加载的模块的不安全路径,允许在特权进程中执行非特权代码。

由于在解析选项时检查不正确,-logfile参数可用于覆盖文件系统中的任意文件。

安全专家MatthewHickey还发布了一个概念验证漏洞利用代码,可以让攻击者以3个或更少的命令接管易受攻击的系统。

X.Org基金会通过发布X.OrgServer版本1.20.3解决了这个漏洞。

主要的发行版,包括OpenBSD,Debian,Ubuntu,CentOS,RedHat和Fedora都发布了CVE-2018-14665漏洞的安全建议。

  • 服务器购买微信群
  • 阿里云&腾讯云&国外VPS
  • weinxin
  • 服务器购买QQ群
  • 阿里云&腾讯云&国外VPS
  • weinxin
CE安全网

发表评论

您必须登录才能发表评论!